Call us: 0300 131 0598

Critical Updates to mail4 and mail2 servers Wednesday 28th January 2026 22:26:25


We are currently peforming critical updates to the mail4.hostinguk.net (also accessed via mail6.hostinguk.net) and mail2.hostinguk.net servers.

Services including POP, IMAP, and SMTP will unavailable until this work is complete, with the maintenance window is expected to last several hours.

We apologise for any difficulties caused by this maintenance causes.

Updates are complete and our engineers are now hands-off.

Should you encounter any issues please contact our support team via ticket from your client area https://billing.hostinguk.net

Updates are complete on both servers and services have been brought back online. We are monitoring both servers closely.