Issue on plesk84.hostinguk.net Wednesday 30th October 2024 12:05:00


We're aware of a problem with the shared hosting server plesk84.hostinguk.net. Our engineers are currently looking into this. We will post an update as soon as we have one.

Issue resolved 12:30 pm

We're aware of a problem with the shared hosting server plesk84.hostinguk.net. Our engineers are currently looking into this. We will post an update as soon as we have one.

Update: server is back online and the issue has been identified, we are still currently monitoring this, if you are still experiencing issues, please open a support ticket.