Issue on cPanel9.hostinguk.net Tuesday 21st May 2024 12:35:00


We are carrying out some emergency maintenance on our cpanel9.hostinguk.net server.

We expect the server to be back up and running shortly. However, we will keep you updated during this process.

Update: services are all up and we are continuing to monitor.

We apologise for an inconvenience caused here.