Issue on Plesk68.myhostcp.com Sunday 17th July 2022 18:00:00


We are aware of an issue on one of our Plesk servers (plesk68.myhostcp.com).

Our engineers are currently looking into this. We will provide you with an update shortly on this.

Update: We are still looking into this issue and will expect the services to be back up shortly.

The issue has now been resolved. We apologise for any inconvenience this has caused you.