Issue on Plesk56.myhostcp.com Thursday 6th January 2022 15:55:00


We're currently aware of an issue affecting the server plesk56.myhostcp.com. This is currently being investigated.

We'll provide further updates as this is progressed.

Update: Services are now back up and running. However, if you experience any further issues, please open a support ticket from your account at https://billing.hostinguk.net/admin/