Issue Affecting Cloud Servers Tuesday 21st September 2021 11:19:00


We're currently investigating an issue with the Cloud platform that is affecting some servers.

Updates will be posted as this issue is progressed.

UPDATE All affected servers are now back up and running. If anyone encounters any issues, please get in touch by opening a ticket from your account at https://billing.hostinguk.net/